Island laggy
Incident Report for yabal
Resolved
Island is working fine again.
Posted May 15, 2022 - 21:08 UTC
Investigating
We are experiencing an issue with the island servers.
Posted May 15, 2022 - 20:57 UTC
This incident affected: Metaverse World.